re = /(?P<number>\d+(\.\d+)?)(?P<quantifier>\W?[a-z,A-Z,А-Я,а-я])?/m
str = 'Необходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end