use strict;
my $str = 'Необходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно';
my $regex = qr/(?P<number>\d+(\.\d+)?)(?P<quantifier>\W?[a-z,A-Z,А-Я,а-я])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}