const regex = new RegExp('(?P<number>\\d+(\\.\\d+)?)(?P<quantifier>\\W?[a-z,A-Z,А-Я,а-я])?', 'gm')
const str = `Необходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}