package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d{10}$)|(^\d{2}\-\d{8}$)|(^\d{3}\-\d{7}$)|(^\d{4}\-\d{6}$)`)
var str = `0123456789
01-23456789
012-3456789
0123-456789
01234-65986
02154445-43`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}