import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{10}$)|(^\\d{2}\\-\\d{8}$)|(^\\d{3}\\-\\d{7}$)|(^\\d{4}\\-\\d{6}$)";
final String string = "0123456789\n"
+ "01-23456789\n"
+ "012-3456789\n"
+ "0123-456789\n"
+ "01234-65986\n"
+ "02154445-43";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}