const regex = /(^\d{10}$)|(^\d{2}\-\d{8}$)|(^\d{3}\-\d{7}$)|(^\d{4}\-\d{6}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{10}$)|(^\\d{2}\\-\\d{8}$)|(^\\d{3}\\-\\d{7}$)|(^\\d{4}\\-\\d{6}$)', 'gm')
const str = `0123456789
01-23456789
012-3456789
0123-456789
01234-65986
02154445-43`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}