$re = '/(^\d{10}$)|(^\d{2}\-\d{8}$)|(^\d{3}\-\d{7}$)|(^\d{4}\-\d{6}$)/m';
$str = '0123456789
01-23456789
012-3456789
0123-456789
01234-65986
02154445-43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);