using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//div\[@id='mat-menu-panel-(\d)']/div/div/a\[4]";
string input = @"//div[@id='mat-menu-panel-0']/div/div/a[4]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}