re = /\/\/div\[@id='mat-menu-panel-(\d)']\/div\/div\/a\[4]/
str = '//div[@id=\'mat-menu-panel-0\']/div/div/a[4]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end