$re = '///div\[@id=\'mat-menu-panel-(\d)\']/div/div/a\[4]/';
$str = '//div[@id=\'mat-menu-panel-0\']/div/div/a[4]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);