// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"//div\[@id='mat-menu-panel-(\d)']/div/div/a\[4]").unwrap();
let string = "//div[@id='mat-menu-panel-0']/div/div/a[4]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}