#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*?(?:\b(?:[sS]alary|[wW]age|[pP]ay)\b).*?([$][\d,.]+\s*[ot-]+\s*[\d$,.]+\d+)"
Local $sString = "“The salary range in Colorado for this role is from USD $123,500 - $185,500”" & @CRLF & _
"" & @CRLF & _
"The budget this year will be from $150,000 to $200,000" & @CRLF & _
"" & @CRLF & _
"“The salary for this role is $180,000 to $216,000”" & @CRLF & _
"The budget this year will be from $150,000 to $200,000" & @CRLF & _
"" & @CRLF & _
"“The salary for this role in the state of Colorado is between $150,800 to $226,000.”" & @CRLF & _
"" & @CRLF & _
"“Pay Range: $12.00 - $16.00”" & @CRLF & _
"" & @CRLF & _
"“Salary Range: $180,000 - $147,000”" & @CRLF & _
"" & @CRLF & _
"“The anticipated starting base pay for this position is: $100,000 to $142,000 per year”" & @CRLF & _
"" & @CRLF & _
"“Hourly wage estimate: $21.49 - $32.24 / hour”" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")