import Foundation
let pattern = #".*?(?:\b(?:[sS]alary|[wW]age|[pP]ay)\b).*?([$][\d,.]+\s*[ot-]+\s*[\d$,.]+\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
“The salary range in Colorado for this role is from USD $123,500 - $185,500”
The budget this year will be from $150,000 to $200,000
“The salary for this role is $180,000 to $216,000”
The budget this year will be from $150,000 to $200,000
“The salary for this role in the state of Colorado is between $150,800 to $226,000.”
“Pay Range: $12.00 - $16.00”
“Salary Range: $180,000 - $147,000”
“The anticipated starting base pay for this position is: $100,000 to $142,000 per year”
“Hourly wage estimate: $21.49 - $32.24 / hour”
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)