# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(?:\b(?:[sS]alary|[wW]age|[pP]ay)\b).*?([$][\d,.]+\s*[ot-]+\s*[\d$,.]+\d+)"
test_str = ("“The salary range in Colorado for this role is from USD $123,500 - $185,500”\n\n"
"The budget this year will be from $150,000 to $200,000\n\n"
"“The salary for this role is $180,000 to $216,000”\n"
"The budget this year will be from $150,000 to $200,000\n\n"
"“The salary for this role in the state of Colorado is between $150,800 to $226,000.”\n\n"
"“Pay Range: $12.00 - $16.00”\n\n"
"“Salary Range: $180,000 - $147,000”\n\n"
"“The anticipated starting base pay for this position is: $100,000 to $142,000 per year”\n\n"
"“Hourly wage estimate: $21.49 - $32.24 / hour”\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.