import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(?:\\b(?:[sS]alary|[wW]age|[pP]ay)\\b).*?([$][\\d,.]+\\s*[ot-]+\\s*[\\d$,.]+\\d+)";
final String string = "“The salary range in Colorado for this role is from USD $123,500 - $185,500”\n\n"
+ "The budget this year will be from $150,000 to $200,000\n\n"
+ "“The salary for this role is $180,000 to $216,000”\n"
+ "The budget this year will be from $150,000 to $200,000\n\n"
+ "“The salary for this role in the state of Colorado is between $150,800 to $226,000.”\n\n"
+ "“Pay Range: $12.00 - $16.00”\n\n"
+ "“Salary Range: $180,000 - $147,000”\n\n"
+ "“The anticipated starting base pay for this position is: $100,000 to $142,000 per year”\n\n"
+ "“Hourly wage estimate: $21.49 - $32.24 / hour”\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}