import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^[ ]{0,}$)^\\S{1,}$";
final String string = "\n"
+ " \n"
+ "abcd\n"
+ "ABCD1234\n"
+ "#$%^&*()_+={}\n"
+ "abc def\n"
+ "ABC 123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}