$re = '/(?!^[ ]{0,}$)^\S{1,}$/m';
$str = '
abcd
ABCD1234
#$%^&*()_+={}
abc def
ABC 123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);