re = /(?!^[ ]{0,}$)^\S{1,}$/m
str = '
abcd
ABCD1234
#$%^&*()_+={}
abc def
ABC 123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end