#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\d.]{18})\d{1,3}(?:\.\d{3})*(?:,\d\d?)?$"
Local $sString = "1.000.000.000.000" & @CRLF & _
"1.000.000.000.000,00" & @CRLF & _
"1" & @CRLF & _
"1,00" & @CRLF & _
"123,45" & @CRLF & _
"10.000.000.000.000" & @CRLF & _
"10.000.000.000.000,00" & @CRLF & _
"10.000.000.000.000.000" & @CRLF & _
"10.000.000.000.000.000,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")