import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\d.]{18})\\d{1,3}(?:\\.\\d{3})*(?:,\\d\\d?)?$";
final String string = "1.000.000.000.000\n"
+ "1.000.000.000.000,00\n"
+ "1\n"
+ "1,00\n"
+ "123,45\n"
+ "10.000.000.000.000\n"
+ "10.000.000.000.000,00\n"
+ "10.000.000.000.000.000\n"
+ "10.000.000.000.000.000,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}