re = /^(?![\d.]{18})\d{1,3}(?:\.\d{3})*(?:,\d\d?)?$/m
str = '1.000.000.000.000
1.000.000.000.000,00
1
1,00
123,45
10.000.000.000.000
10.000.000.000.000,00
10.000.000.000.000.000
10.000.000.000.000.000,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end