#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:[a-z]+(?:(?!\n)[^a-z])+){3}((?=(?:(?![aeiou])[a-z])*[aeiou](?:(?![aeiou])[a-z])*[^a-z](*SKIP)(?!)|)[a-z]+)"
Local $sString = "Here is my Text which " & @CRLF & _
"I now have *starred* the words which i would like accounted for"" & @CRLF & _
"I would like the end result to be Lines 3 Words 6." & @CRLF & _
"Python Regular expression **rules** have me trying things that " & @CRLF & _
"I have listed below. All of them are usable but I would like " & @CRLF & _
"To understand how to customize it for **production** to use."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")