$re = '/(?:[a-z]+(?:(?!\n)[^a-z])+){3}((?=(?:(?![aeiou])[a-z])*[aeiou](?:(?![aeiou])[a-z])*[^a-z](*SKIP)(?!)|)[a-z]+)/i';
$str = 'Here is my Text which
I now have *starred* the words which i would like accounted for"
I would like the end result to be Lines 3 Words 6.
Python Regular expression **rules** have me trying things that
I have listed below. All of them are usable but I would like
To understand how to customize it for **production** to use.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);