const regex = /(?:[a-z]+(?:(?!\n)[^a-z])+){3}((?=(?:(?![aeiou])[a-z])*[aeiou](?:(?![aeiou])[a-z])*[^a-z](*SKIP)(?!)|)[a-z]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-z]+(?:(?!\\n)[^a-z])+){3}((?=(?:(?![aeiou])[a-z])*[aeiou](?:(?![aeiou])[a-z])*[^a-z](*SKIP)(?!)|)[a-z]+)', 'gi')
const str = `Here is my Text which
I now have *starred* the words which i would like accounted for"
I would like the end result to be Lines 3 Words 6.
Python Regular expression **rules** have me trying things that
I have listed below. All of them are usable but I would like
To understand how to customize it for **production** to use.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}