#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(?<!\\)[,>]\s*"
Local $sString = "keyword\\,one > sub" & @CRLF & _
"one\\,two\\,three, four" & @CRLF & _
"keywordOne\\\\" & @CRLF & _
"keyword\\\\, keywordTwo" & @CRLF & _
"keywordOne\\,, keywordTwo" & @CRLF & _
"keyword\\,one, keywordTwo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")