re = /\s*(?<!\\)[,>]\s*/m
str = 'keyword\\\\,one > sub
one\\\\,two\\\\,three, four
keywordOne\\\\\\\\
keyword\\\\\\\\, keywordTwo
keywordOne\\\\,, keywordTwo
keyword\\\\,one, keywordTwo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end