using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?<!\\)[,>]\s*";
string input = @"keyword\\,one > sub
one\\,two\\,three, four
keywordOne\\\\
keyword\\\\, keywordTwo
keywordOne\\,, keywordTwo
keyword\\,one, keywordTwo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}