$re = '/\s*(?<!\\\\)[,>]\s*/m';
$str = 'keyword\\\\,one > sub
one\\\\,two\\\\,three, four
keywordOne\\\\\\\\
keyword\\\\\\\\, keywordTwo
keywordOne\\\\,, keywordTwo
keyword\\\\,one, keywordTwo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);