const regex = /^(?<firstchar>(?=[A-Za-z]))((?<alphachars>[A-Za-z])|(?<specialchars>[A-Za-z]['-](?=[A-Za-z]))|(?<spaces> (?=[A-Za-z])))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<firstchar>(?=[A-Za-z]))((?<alphachars>[A-Za-z])|(?<specialchars>[A-Za-z][\'-](?=[A-Za-z]))|(?<spaces> (?=[A-Za-z])))*$', 'gm')
const str = `#First Name must contain letters only. It may contain spaces, hyphens, or apostrophes.
First name-and hy-phen's
#It must begin with letters.
First name
1shouldn't match
'shouldn't match
#All other characters and numbers are not valid.
Should match
Should not m@tch
Should not m#tch
#Special characters ‘ and – cannot be together (e.g. John’-s is not allowed)
Allow'd
NotAllow-'d
NotAllow'-d
#An alphabet should be present before and after the special characters ‘ and – (e.g. John ‘s is not allowed)
Allow'd
Also A'llowed
A'llowd
Not Allowd'
Not 'Allowd
#Two consecutive spaces are not allowed (e.g. Annia St is not allowed)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}