use strict;
my $str = '#First Name must contain letters only. It may contain spaces, hyphens, or apostrophes.
First name-and hy-phen\'s
#It must begin with letters.
First name
1shouldn\'t match
\'shouldn\'t match
#All other characters and numbers are not valid.
Should match
Should not m@tch
Should not m#tch
#Special characters ‘ and – cannot be together (e.g. John’-s is not allowed)
Allow\'d
NotAllow-\'d
NotAllow\'-d
#An alphabet should be present before and after the special characters ‘ and – (e.g. John ‘s is not allowed)
Allow\'d
Also A\'llowed
A\'llowd
Not Allowd\'
Not \'Allowd
#Two consecutive spaces are not allowed (e.g. Annia St is not allowed)
';
my $regex = qr/^(?<firstchar>(?=[A-Za-z]))((?<alphachars>[A-Za-z])|(?<specialchars>[A-Za-z]['-](?=[A-Za-z]))|(?<spaces> (?=[A-Za-z])))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}