# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<firstchar>(?=[A-Za-z]))((?<alphachars>[A-Za-z])|(?<specialchars>[A-Za-z]['-](?=[A-Za-z]))|(?<spaces> (?=[A-Za-z])))*$"
test_str = ("#First Name must contain letters only. It may contain spaces, hyphens, or apostrophes.\n"
"First name-and hy-phen's\n"
"#It must begin with letters.\n"
"First name\n"
"1shouldn't match\n"
"'shouldn't match\n"
"#All other characters and numbers are not valid.\n"
"Should match\n"
"Should not m@tch\n"
"Should not m#tch\n"
"#Special characters ‘ and – cannot be together (e.g. John’-s is not allowed)\n"
"Allow'd\n"
"NotAllow-'d\n"
"NotAllow'-d\n"
"#An alphabet should be present before and after the special characters ‘ and – (e.g. John ‘s is not allowed)\n"
"Allow'd\n"
"Also A'llowed\n"
"A'llowd\n"
"Not Allowd'\n"
"Not 'Allowd\n"
"#Two consecutive spaces are not allowed (e.g. Annia St is not allowed)\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.