$re = '/^(?<firstchar>(?=[A-Za-z]))((?<alphachars>[A-Za-z])|(?<specialchars>[A-Za-z][\'-](?=[A-Za-z]))|(?<spaces> (?=[A-Za-z])))*$/m';
$str = '#First Name must contain letters only. It may contain spaces, hyphens, or apostrophes.
First name-and hy-phen\'s
#It must begin with letters.
First name
1shouldn\'t match
\'shouldn\'t match
#All other characters and numbers are not valid.
Should match
Should not m@tch
Should not m#tch
#Special characters ‘ and – cannot be together (e.g. John’-s is not allowed)
Allow\'d
NotAllow-\'d
NotAllow\'-d
#An alphabet should be present before and after the special characters ‘ and – (e.g. John ‘s is not allowed)
Allow\'d
Also A\'llowed
A\'llowd
Not Allowd\'
Not \'Allowd
#Two consecutive spaces are not allowed (e.g. Annia St is not allowed)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);