using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""([^\""]+)\""|\b[A-Z]";
string input = @"Department of the Federal Treasury ""IFTS No. 43""
Federal Treasury Company ""Light-8""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}