re = /\"([^\"]+)\"|\b[A-Z]/m
str = 'Department of the Federal Treasury "IFTS No. 43"
Federal Treasury Company "Light-8"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end