package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"([^\"]+)\"|\b[A-Z]`)
var str = `Department of the Federal Treasury "IFTS No. 43"
Federal Treasury Company "Light-8"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}