$re = '/\"([^\"]+)\"|\b[A-Z]/m';
$str = 'Department of the Federal Treasury "IFTS No. 43"
Federal Treasury Company "Light-8"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);