using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\%key:((?:[a-z0-9-_]+|[:]{2})*)\%\]";
string input = @"[%key:component::bluetooth::config::step::bluetooth_confirm::description]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}