const regex = /\[\%key:((?:[a-z0-9-_]+|[:]{2})*)\%\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\%key:((?:[a-z0-9-_]+|[:]{2})*)\\%\\]', 'gm')
const str = `[%key:component::bluetooth::config::step::bluetooth_confirm::description]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}