$re = '/\[\%key:((?:[a-z0-9-_]+|[:]{2})*)\%\]/m';
$str = '[%key:component::bluetooth::config::step::bluetooth_confirm::description]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);