package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\%key:((?:[a-z0-9-_]+|[:]{2})*)\%\]`)
var str = `[%key:component::bluetooth::config::step::bluetooth_confirm::description]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}