# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("\w+)(\[")/\1":\2/gm;t' <<< "{\"ips\":{\"ingress\":{\"all[\"104.16.51.111/32\",\"104.16.53.111/32\"],\"specific[\"104.16.51.111/32\",\"104.16.53.111/32\"]},\"egress\":{\"all[\"216.198.0.0/18\",\"52.27.183.82/32\"],\"specific\":[\"216.198.0.0/18\",\"54.88.153.44/32\"]}}}"