// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("\w+)(\[")"#).unwrap();
let string = "{\"ips\":{\"ingress\":{\"all[\"104.16.51.111/32\",\"104.16.53.111/32\"],\"specific[\"104.16.51.111/32\",\"104.16.53.111/32\"]},\"egress\":{\"all[\"216.198.0.0/18\",\"52.27.183.82/32\"],\"specific\":[\"216.198.0.0/18\",\"54.88.153.44/32\"]}}}";
let substitution = "\\1\":\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}