import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"\\w+)(\\[\")";
final String string = "{\"ips\":{\"ingress\":{\"all[\"104.16.51.111/32\",\"104.16.53.111/32\"],\"specific[\"104.16.51.111/32\",\"104.16.53.111/32\"]},\"egress\":{\"all[\"216.198.0.0/18\",\"52.27.183.82/32\"],\"specific\":[\"216.198.0.0/18\",\"54.88.153.44/32\"]}}}";
final String subst = "\\1\":\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}