$re = '/("\w+)(\[")/m';
$str = '{"ips":{"ingress":{"all["104.16.51.111/32","104.16.53.111/32"],"specific["104.16.51.111/32","104.16.53.111/32"]},"egress":{"all["216.198.0.0/18","52.27.183.82/32"],"specific":["216.198.0.0/18","54.88.153.44/32"]}}}';
$subst = "\1\":\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;