import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*)\\b(\\d+\\.\\d+\\.\\d+)\\b([\\s\\S]*)";
final String string = "Microsoft (R) Windows Script Host Version 5.8\n"
+ "Copyright (C) Microsoft Corporation. All rights reserved.\n\n"
+ "58.0.3029 Copyright 2011 Google Inc.";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}