re = /([\s\S]*)\b(\d+\.\d+\.\d+)\b([\s\S]*)/m
str = 'Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.
58.0.3029 Copyright 2011 Google Inc.'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result