#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\.\s][\w\-\.{2,}]+@([\w-]+\.)+[\w-]{2,}$"
Local $sString = "e..mail@mail.com" & @CRLF & _
".email@mail.com" & @CRLF & _
"..email@mail.com" & @CRLF & _
"email.@mail.com" & @CRLF & _
"email..@mail.com" & @CRLF & _
"e@mail@mail.com" & @CRLF & _
"@email@mail.com" & @CRLF & _
"email@mail.com@" & @CRLF & _
"#email@mail.com" & @CRLF & _
"~email@mail.com" & @CRLF & _
"!email@mail.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")