$re = '/^[^\.\s][\w\-\.{2,}]+@([\w-]+\.)+[\w-]{2,}$/m';
$str = 'e..mail@mail.com
.email@mail.com
..email@mail.com
email.@mail.com
email..@mail.com
e@mail@mail.com
@email@mail.com
email@mail.com@
#email@mail.com
~email@mail.com
!email@mail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);