package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\.\s][\w\-\.{2,}]+@([\w-]+\.)+[\w-]{2,}$`)
var str = `e..mail@mail.com
.email@mail.com
..email@mail.com
email.@mail.com
email..@mail.com
e@mail@mail.com
@email@mail.com
email@mail.com@
#email@mail.com
~email@mail.com
!email@mail.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}