using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h+\K\p{Lu}+\pL+(?:\h+\pL+)*(?:\h+\([^()]+\))?";
string input = @"А здесь у нас Название название (и доп информация)
А здесь у нас Название";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}